Beam SDK for Python dependencies

The Beam SDKs depend on common third-party components which then import additional dependencies. Version collisions can result in unexpected behavior in the service. If you are using any of these packages in your code, be aware that some libraries are not forward-compatible and you may need to pin to the listed versions that will be in scope during execution.

2.8.0

Beam SDK for Python 2.8.0 has the following compile and runtime dependencies.

PackageVersion
avro>=1.8.1, <2.0.0
crcmod>=1.7, <2.0
dill>=0.2.6, <=0.2.8.2
fastavro>=0.21.4, <0.22
future>=0.16.0, <1.0.0
futures>=3.1.1, <4.0.0
grpcio>=1.8, <2
hdfs>=2.1.0, <3.0.0
httplib2>=0.8, <=0.11.3
mock>=1.0.1, <3.0.0
oauth2client>=2.0.1, <5
protobuf>=3.5.0.post1, <4
pydot>=1.2.0, <1.3
pytz>=2018.3, <=2018.4
pyyaml>=3.12, <4.0.0
pyvcf>=0.6.8, <0.7.0
six>=1.9, <1.12
typing>=3.6.0, <3.7.0

Previous releases

2.7.0

Beam SDK for Python 2.7.0 has the following compile and runtime dependencies.

PackageVersion
avro>=1.8.1, <2.0.0
crcmod>=1.7, <2.0
dill>=0.2.6, <=0.2.8.2
fastavro==0.19.7
future>=0.16.0, <1.0.0
futures>=3.1.1, <4.0.0
grpcio>=1.8, <2
hdfs>=2.1.0, <3.0.0
httplib2>=0.8, <=0.11.3
mock>=1.0.1, <3.0.0
oauth2client>=2.0.1, <5
protobuf>=3.5.0.post1, <4
pydot>=1.2.0, <1.3
pytz>=2018.3, <=2018.4
pyyaml>=3.12, <4.0.0
pyvcf>=0.6.8, <0.7.0
six>=1.9, <1.12
typing>=3.6.0, <3.7.0